[Résolu] Problème redirection de ports

Répondre
Avatar du membre
Nitro
Osef
Osef
Messages : 2432
Enregistré le : 19 septembre 2012, 11:00
Localisation : Normandy, what else ?

[Résolu] Problème redirection de ports

Message par Nitro » 12 novembre 2017, 16:11

Yep

Je viens de me rendre compte que mon serveur n'accède plus au DL d'un torrent.
J'ai voulu lancer un raspbian, et rien aucune source. Je suis sur que cela devrait fonctionner pour l'avoir déjà fait.
Ce problème est apparut depuis ma nouvelle configuration réseau.
Mon serveur est raccordé sur le routeur esclave. Mais comme je n'utilise pas le port WAN, cela ne doit pas influencer sur la redirection. Je me serais posé la question s'il était en WiFi, mais ce n'est pas le cas.

Je n'ai rien changé côté box, avec mon port xxxx dirigé vers l'ip de mon routeur maitre
Au niveau du routeur maitre, j'ai dans forwarding/virtual server. service port : xxxx (mon port déclaré dans la box et dans transmission), ip celle de mon serveur et port interne xxxx le même. Protocole j'ai mis TCP et UDP (la valeur est sur all), le status est bien sur sur enable.

J'ai testé en redirigeant sur mon pc, et en laçant advanced port scanner. Il ne voit pas le port ouvert.
Ça fait deux plombes que je suis dessus et là je sèche.

Avatar du membre
KrisStaDream
Team OSEF
Team OSEF
Messages : 1468
Enregistré le : 19 septembre 2012, 11:52
Localisation : Entre ici et la-bas, dans un monde de plus en plus fou !

Re: Problème redirection de ports

Message par KrisStaDream » 12 novembre 2017, 16:15

bois un coup pour ne pas te déshydrater de trop :LOL:

Dsl je ne peux pas t'aider ich bin noob dans le tripotage de porc :lol:
Image

Avatar du membre
Tom23
Osef
Osef
Messages : 1415
Enregistré le : 19 septembre 2012, 11:05

Re: Problème redirection de ports

Message par Tom23 » 12 novembre 2017, 17:36

Ce qui m'étonne c'est qu'il est de moins en moins nécessaire de rediriger des ports pour faire du torrent.
Je viens de regarder je n'ai aucun port redirigé vers mon serveur pour le torrent.

Les FAI préfèrent brider le débit sur ce genre de protocoles ou de faire mentir leurs DNS pour pénaliser les vilains pirates.

Je sais que pour scanner des ports j'utilisais nmap sous linux. J'ai testé rapido sur l'ip que tu utilises d'habitude pour venir sur le forum et je vois aucun port ouvert. Mais je ne garantis pas avoir fait ça correctement.

Tu as testé la résolution DNS sur ton serveur ? Sous linux il y a dig qui marche très bien pour ça.
Image Image

"Le Cloud, ça n'existe pas. Ce sont simplement les ordinateurs de quelqu'un d'autre !" -The Free Software Foundation

Avatar du membre
Nitro
Osef
Osef
Messages : 2432
Enregistré le : 19 septembre 2012, 11:00
Localisation : Normandy, what else ?

Re: Problème redirection de ports

Message par Nitro » 12 novembre 2017, 19:44

Tom23 a écrit :
12 novembre 2017, 17:36
J'ai testé rapido sur l'ip que tu utilises d'habitude pour venir sur le forum et je vois aucun port ouvert.
Si aucun programme n'est à l'écoute du port, normal que tu le vois fermé.
Dig connais pas je vais checker

Edit: en voulant faire un apt update, je me rend compte que le serveur n'accède pas à internet. J'ai une piste à creuser.

Avatar du membre
Tom23
Osef
Osef
Messages : 1415
Enregistré le : 19 septembre 2012, 11:05

Re: Problème redirection de ports

Message par Tom23 » 12 novembre 2017, 20:02

Un port ouvert sur ton ip est ouvert qu'une appli écoute ou pas.
Image Image

"Le Cloud, ça n'existe pas. Ce sont simplement les ordinateurs de quelqu'un d'autre !" -The Free Software Foundation

Avatar du membre
Nitro
Osef
Osef
Messages : 2432
Enregistré le : 19 septembre 2012, 11:00
Localisation : Normandy, what else ?

Re: Problème redirection de ports

Message par Nitro » 12 novembre 2017, 20:04

D'après mes premières recherches, on ouvre pas un port sur un routeur. On le redirige c'est ce qui explique ma réponse.

Avatar du membre
Tom23
Osef
Osef
Messages : 1415
Enregistré le : 19 septembre 2012, 11:05

Re: Problème redirection de ports

Message par Tom23 » 12 novembre 2017, 20:09

C'est bizarre, si je fais un nmap chez moi, j'ai une liste de ports ouverts, dont certains n'arrivent sur aucune machine en marche.
J'irai pas chercher pourquoi, ça ne donne pas grand chose dans ton cas.
Mais oui, regarde du côté de dig, au pire ça éliminera une piste.
Image Image

"Le Cloud, ça n'existe pas. Ce sont simplement les ordinateurs de quelqu'un d'autre !" -The Free Software Foundation

Avatar du membre
Jambo
Messages : 1547
Enregistré le : 19 septembre 2012, 15:11

Re: Problème redirection de ports

Message par Jambo » 13 novembre 2017, 12:35

Quel tracker et quel client sur quel machine, config DNS du réseau on veut tout savoir :D ?

Check tes DNS comme la dit Tom, Dig est géniale mais si tu veux aussi du DNS tool sous winwin il y a Nslookup.

J'ai fait un peu joujou avec Nmap sur une IP public c'est relou tu peut pas scanner tout les ports il faut le faire par tranche.
Mais bon méfiance dans le scan d'IP public ...

Sinon côté FireWall tu as check ?

NAT/Port forwarding http://www.figer.com/Publications/nat.htm#530

Dans tout les cas bonne recherche

:smack:
La vie privée est un droit, pas un privilège.

Image

Avatar du membre
Nitro
Osef
Osef
Messages : 2432
Enregistré le : 19 septembre 2012, 11:00
Localisation : Normandy, what else ?

Re: Problème redirection de ports

Message par Nitro » 13 novembre 2017, 19:21

Problème résolu, j'avais gardé l'ancienne config. La passerelle n'était plus à la bonne adresse.
Pour détailler à l'origine j'avais paramétré mon serveur en ip fixe.
Depuis c'est devenu une généralité chez moi, et du coup c'était géré directement sur le routeur.
Donc voilà, je savais que ça venait du serveur mais je ne comprenais pas comment.
En checkant la conf de la carte, ça m'a sauté aux yeux.

Entre temps à force de chercher, je me suis retrouvé avec un gros bug. Mes baux DHCP ne correspondaient pas du tout à ma table.
J'ai du me résoudre à vider et reprogrammer entièrement mon routeur maître.
Me reste que le serveur non accessible via le réseau. Demain je lui colle un ensemble moniteur clavier souris. Et je remet en dhcp.

J'anticipe la question "pourquoi as-tu modifié les adresses de nouveaux routeurs?"
Tout simplement car je les ai configuré avec l'ancien réseau actif.

Note: j'ai viré les redirections inutiles (tu avais raison Tom). Il me semblais qu'il avait fallu le faire sur mes anciens routeurs. Mais bon comme j'ai beaucoup tâtonné à l'époque, rien n'est sur.

Répondre

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 0 invité